NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » COM port question and initialload problem

May 25, 2009
by kpw1
kpw1's Avatar

Hi,

I'm trying program my chip for the first time using a Windows Vista machine with the USB-to-Serial converter. I installed the "PL-2303 Vista Driver Installer.exe" file from the NerdKits driver downloads zip package.

On page 40 of the NerdKits Guide, it describes having to go to Control Panel > Device Manager > Ports (COM & LPT) to see which COM port the "Prolific USB-to-Serial" is connected to. Under Device Manager, however, I see no line that says "Ports (COM & LPT)". I click "View > Show hidden devices" but still see not "Ports (COM & LPT) option.

Eager to move on, I decided to hope for the best (that COM# was less than 5) and change the Makefile until I came across a COM# that didn't give me an immediate error message. COM3 worked for me (though I'd still like to know how to see the Ports (COM & LPT) device).

My LCD still gives the default "Congrats your hardware is working" message. I unplug the battery, make sure the programming switch is up, and re-plug in the battery. My LCD then has the first and third lines "blacked out".

Then, I try to run the "make" command:

C:\Users\Kerry Wang\Desktop\NerdKits\Code\initialload>make
avrdude -c avr109 -p m168 -b 115200 -P COM3 -U flash:w:initialload.hex:a

Connecting to programmer: .

After waiting for about 2-3 minutes, I get the following error message:

Found programmer: Id = "S ""; type = p
    Software Version = V. ; Hardware Version = v.
avrdude: error: buffered memory access not supported. Maybe it isn't 
a butterfly/AVR109 but a AVR910 device?  
make: *** [initialload-upload] Error 1

Can anyone help with these issues? Any assistance would greatly be appreciated. Thanks.

PS: Happy Memorial Day. Hope everyone had some time to think about those who served in the armed services.

May 27, 2009
by BOTRS
BOTRS's Avatar

Hey kpw

I had the same problem that you did

avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?

By going back and doing everything stepwise turning the switch to the up position THEN plugging in the battery it corrected itself.

Mine also took a longtime after hitting make to communicate with the chip but only when it didn't work. When it did work it went really quick.

June 07, 2009
by pamdemonia
pamdemonia's Avatar

I had the same problem, but then when I really shoved the serial connector into the programming board, it worked fine!

October 04, 2009
by guitfiddlerb0b
guitfiddlerb0b's Avatar

I just got my nk yesterday and am having the exact same problem as kpw1. i tried what botrs and pamdemonia have suggested but it still isn't working. anyone have any more suggestions?

October 06, 2009
by rusirius
rusirius's Avatar

Just because that com port didn't have an error doesn't mean it's the right one.. It's possible it could be a modem or some other device...

If you don't see the "Ports (LPT & COM)" section in device manager then there is definately a problem... If the driver is installed correctly and working you'll see it listed there exactly as described...

First thing I would do is make sure to do a full reboot of the system (and leave the adaptor connected while doing so...)

If it still doesn't show up, then try clicking the "Scan for Hardware Changes" button... After that runs, see if it shows up... If it still doesn't work, then maybe try the device in another machine to make sure the adapter isn't bad... If it works there then you know it's an issue with the machine... Could be any number of things... A bad USB root device, incorrect driver for the root USB device, etc.. You can also try switching it to a different USB port (preferably not the one right beside the current one) and see if that makes any difference...

Last but not least, if it's a laptop, make sure the root USB device isn't powered down... Check in the power options and make sure there isn't an option to power them down (sometimes they do to conserve battery power)...

October 08, 2009
by guitfiddlerb0b
guitfiddlerb0b's Avatar

Thanks rusirius, i was able to find the correct com port within the device manager LPT & COM, and then USB to Ser. I then saved the COM# to the makefile, but the problem still persists when i type make into the command prompt, (as in i get the same message) although it takes a matter of seconds as opposed to minutes to attempt to compile. Do think there might be a problem with the communication in the chip that's connected to the USB converter?

October 08, 2009
by rusirius
rusirius's Avatar

Well, that's pretty easy to check... Do this...

First make absolutely SURE the positive and negative (Red and Black) leads of the serial adapter (not the USB to serial, but the nerdkit inverter) are in the right spots and getting power...

Second, take both the green and yellow wires and twist them together...

Third, run hyperterm or putty or some other serial console... Set it for something like 115200, 8, N, 1 and NO FLOW CONTROL!...

Then type... (in the terminal that is)...

If you see the characters get "echoed" back (i.e. you can see what you type) then you are getting communications through the USB to serial adapter as well as the adapter...

No if you DON'T get characters back, then here's the next step...

Go ahead and disconnect the power from the nerdkit adapter (again, not the USB one, the TTL inverter). Now look on the bottom of the board... Pins 2 and 3 are the Tx and Rx of the serial port... If the "plug" is facing straight towards your body, then the top LEFT of the 9 pins of the plug is pin 1 (you'll note it's marked by a SQUARE pad instead of a round one... Now the next two pins going to the right are pins 2 and 3... You need to use something (or get someone to help) to short those two pins together... Use a small screwdriver (flat blade small "electronic" type screwdriver would work well), or whatever... In a pinch you can probably just use a small piece of stripped wire from the kit... Just make sure it's making good contact... It wouldn't hurt to "scrape" the pins with a small knife first just to make sure there isn't any soldering flux built up on the outside...

While these pins are shorted do the exact same thing... (type characters in the terminal)... If you don't see them even now, it looks like the USB to serial adapter is either bad or still not loaded right... If you are getting it, then go back to hooking up the adapter and DOUBLE CHECK that it's getting power... If it definately is, and the loopback still doesn't work, then it may be a bad adapter and I'm sure the "nerds" will send ya another one to replace it...

October 31, 2009
by jingham06
jingham06's Avatar

I too have this error. Anyone find a work around or why it's doing it?

October 31, 2009
by mrobbins
(NerdKits Staff)

mrobbins's Avatar

Hi jingham06,

Please see my reply in your other thread and let me know if that fixes your issue. Best,

Mike

Post a Reply

Please log in to post a reply.

Did you know that negative numbers are represented in two's complement notation in binary? Learn more...