NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Project Help and Ideas » Initialload.c Help

April 28, 2010
by azantel
azantel's Avatar

I downloaded the source code and other programs within the member section but cant seem to locate the initialload.c file. Any help would be great, thanks.

April 29, 2010
by Rick_S
Rick_S's Avatar

I just re-downloaded the file to confirm nothing had changed since my last download. One of the sub-folders in is called initialload. Insisde that folder is initialload.c and Makefile.

Are you sure you downloaded from the link labeled NerdKits Sample Source Code ?


December 09, 2011
by Tinkerer
Tinkerer's Avatar

I'm on pg 41 of the Guide and can't seem to list initialload.c. When I open up Programmers Notepad there are no folders listed. After downloading the Sample Source Code there doesn't seem to be any way to read it with the Programmers Notepad. If I read it with the Windows Notepad I only get the title line with no further instructions. What am I doing wrong?

December 10, 2011
by Rick_S
Rick_S's Avatar

The sample source code is a zip file. Did you unzip it? If so, it should create a code folder with several sub-folders in it. On of which is initialload. Inside that folder, you'll find the Makefile and initialload.c

Do not change the folder structure, it must remain intact for the dependencies to resolve properly.


March 10, 2012
by ACT
ACT's Avatar

when we download the file and extract all it tells us that the file is empty.can you help us get the proper files. thank you

March 10, 2012
by Rick_S
Rick_S's Avatar

I've seen one other person have an issue like that. I don't know what the issue was, but they downloaded the file on a different computer and it worked if I remember right. Maybe try that if you have access to a different computer. If that doesn't work, send an email to support at nerdkits dot com and Humberto or Mike will email you the file. You could also try a different browser to download the file... I'm not sure what would corrupt the zip.

BTW, I just checked the zip here by downloading it again and it came through fine.


March 12, 2012
by hevans
(NerdKits Staff)

hevans's Avatar


What operating system are you on? If it is a modern windows, then you should be able to double click the file and will open up like a normal folder. Then click and drag the Code folder out to your desktop (or some other place on your hard drive).


January 04, 2013
by whiltonsimon_1
whiltonsimon_1's Avatar

Hey my name is Whilton and im new to nerdkit and upon trying to load the initial load program i get the following error

"make.exe" all make -C ../libnerdkits make: ../libnerdkits: No such file or directory. Stop. make.exe: [initialload.hex] Error 2

Process Exit Code: 2 Time Taken: 00:01

this is the make file as it is now

GCCFLAGS=-g -Os -Wall -mmcu=atmega168 LINKFLAGS=-Wl,-u,vfprintf -lprintf_flt -Wl,-u,vfscanf -lscanf_flt -lm AVRDUDEFLAGS=-c avr109 -p m168 -b 115200 -P COM2 LINKOBJECTS=../libnerdkits/delay.o ../libnerdkits/lcd.o ../libnerdkits/uart.o

all: initialload-upload

initialload.hex: initialload.c make -C ../libnerdkits avr-gcc ${GCCFLAGS} ${LINKFLAGS} -o initialload.o initialload.c ${LINKOBJECTS} avr-objcopy -j .text -O ihex initialload.o initialload.hex

initialload.ass: initialload.hex avr-objdump -S -d initialload.o > initialload.ass

initialload-upload: initialload.hex avrdude ${AVRDUDEFLAGS} -U flash:w:initialload.hex:a

Thanks for any help i can get

January 04, 2013
by Ralphxyz
Ralphxyz's Avatar

Hi Whilton, your path is not correct!!

What OS are you on?

If you are on Windows your path should look something like this:


It is sometimes easiest to just download the Nerdkits Download again and watch out for the unzip folder location.


January 04, 2013
by whiltonsimon_1
whiltonsimon_1's Avatar

ok sorry im new to programming the windows path where should i be doing this in the command prompt or the programmers notepad i've tried in both and got the same error in both

January 04, 2013
by Ralphxyz
Ralphxyz's Avatar

You need to change your folder structure!!

When you unzipped the Nerdkits Download you did not unzip the files correctly, that is why I said to download them again this time pay attention to how you unzip them.

Your folder structure should look like:


Make a folder Nerdkits on your C: drive then unzip the Code folder to it.

Or you can just manually cleanup what you have all ready downloaded.

Currently your initialload folder is not in the Code folder, Code needs to be the parent of initialload.

I use the Nerdkits folder for all of the other downloads like the specsheet, whicdh you will need and that keeps everything together.


January 04, 2013
by pcbolt
pcbolt's Avatar

Hi Whilton -

Your directory structure should look something like this...

  • /Nerdkits
    • /libnerdkits
    • /initialload
    • /other projects

The "makefile" you are using which is located inside the "initialload" folder is referencing the "libnerdkits" folder using a relative path (the "../libnerkits" notation) so the "initialload" folder and the "libnerdkits" folder must have the same parent folder.

January 05, 2013
by Ralphxyz
Ralphxyz's Avatar

pcbolt, usually there is a Code folder that is the parent of libnerkits and initialload.

At least there is a Code folder in the download.

How did you get the notations? I have gotten them before but always by accident when I was just messing around but I forget how to do them.


Post a Reply

Please log in to post a reply.

Did you know that an electroluminescent backlight for an LCD panel requires hundreds of volts AC to run? Learn more...