NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Everything Else » How To: Embed Images in Forum Posts

March 01, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

We have had a couple of suggestions from the NerdKits community about allowing image uploads in our forum. While we are not ready to host these images ourselves at this time, we are highlighting here a set of best practices for getting images on our forum that should alleviate the problem.

In your forum post, use the following syntax to embed your image:

![Alt Text](Direct Link)

A few notes:

  1. The exclamation point is necessary. Otherwise, it will be interpreted as a link to the image and not an embedded image in your post.
  2. Alt Text can be anything you want. This is is the alternative text that appears if for some reason your image is not accessible. You can choose to replace this with the title of your image.
  3. Direct Link should be replaced with the URL of the image. (Note: this must be the URL of the image itself, not the URL of a webpage that holds the image.) If you already use a photo sharing service that allows you to directly link to images (Photobucket, Flickr, etc) then you can use that. If not, read on.

After a little bit of research, we are recommending imgur as the service of choice for uploading images. Imgur is free, you don't have to sign up for account with them if you don't want to, and it allows direct linking to images.

Here is how to embed an image using ImageShack:

  1. Go to (Control+Click the link to open in a new Tab/Window)
  2. Click Computer, and select the image you want to upload.
  3. Click Start Upload
  4. imgur will then show your image and a list of different links you can use for your image. The "Direct Link" is the one you want to use. Copy it and use that URL as the Direct Link in your post.

Creating an account with imgur is not necessary, but we do recommend it. Creating an account will ensure that your image is available from them forever.

Special Note: It is also possible to have a link to the image without embedding the image in your post. To do this simply leave out the ! to make it into a normal link. In this case the text between the [ ] will be the link text. If you are linking images in this way from imgur you can copy the URL in the "Link" box instead of "Direct Link." Photobucket and Flickr will also allow you to link to their images this way.

April 04, 2011
by abd445
abd445's Avatar

I tried posting the images through image shack using the following syntax but all it showed was "Alt Text" in my post.

"[Alt Text]"(

Ignore the quotes. Also I had the exclamation mark too.

April 04, 2011
by hevans
(NerdKits Staff)

hevans's Avatar

Hi abd445,

You are encountering this problem because you are linking to the page on ImageShack with your image on it, not the "direct" link to the image. The direct link to your image, which can be found on the sidebar on the right side is:

["abd445's pic"](

Which would render like so:

"abd445's pic"

April 22, 2011
by 6776nft6mfa632dt7rgw
6776nft6mfa632dt7rgw's Avatar

Hi Ikeeep getting this same error when I type make. I hope Im' sending an image of my problem.

April 22, 2011
by Ralphxyz
Ralphxyz's Avatar

Did you mean something like ![](

As in:

You can search the Nerdkits forum for "butterfly" to see lots of discussions.

First thing is a wiring error next a low battery but most likely a wiring error.

Sometimes it is simplest to just strip the breadboard and start over, you'll be amazed how fast you get at rewiring the breadboard once you get through doing it 10-20 times.


June 14, 2011
by sdrougas
sdrougas's Avatar

Hi to All, I am very new to the Nerdkits, I am very good with any kind of hardware but not to good with interface. so i downloaded the first code "initialload" and i use win7,64 bit and when i type on the directory makefile i get all this nice errors. any one can tell me what i do wrong or what i do right? or what i have to include in the dir that it is not there? thanks.


June 14, 2011
by missle3944
missle3944's Avatar

Hi sdrougas,

Welcome to the forums. Many people get the same problem too with win 7. I had the same problem too. It looks like you just need to download the win 7 driver here . The usb driver link is right below the Library Title. Hope this Helps!


June 15, 2011
by sdrougas
sdrougas's Avatar

Thanks for your help Missle3944, i got it, it works now.

August 19, 2011
by eiyenla
eiyenla's Avatar

Could you please help me out, I have been receiving similar error 1 message shown on the picture above. I reconected all the bredford and it is still giving me the same error message. How do I go from here?

August 19, 2011
by missle3944
missle3944's Avatar

Hi eiyenla,

What problem do you mean? You should start your own topic because this isn't a help type section for programming and stuff like that. Welcome to the forums :).


Post a Reply

Please log in to post a reply.

Did you know that you can generate hundreds of volts AC from your microcontroller with a little bit of circuitry? Learn more...