NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » There's no cu.PL2303-0000211A file present in /dev directory

December 11, 2011
by jeffspc88mx
jeffspc88mx's Avatar

Using Mac USB after AVR install. I'm looking in /dev for the cu.PL2303-0000211A file and there's nothing even remotely like it, just a couple of bluetooth things. There's nothing with "USB" in the name - mostly ttyxxx and ptyxx stuff. Is there another /dev somewhere else?

The USB - serial device IS showing up under system info when plugged in as:

USB-Serial Controller:

  Product ID:   0x2303
  Vendor ID:    0x067b  (Prolific Technology, Inc.)
  Version:  3.00
  Speed:    Up to 12 Mb/sec
  Manufacturer: Prolific Technology Inc.
  Location ID:  0x04100000 / 4

I've installed AVR MacPack (twice) and I changed to gcc4.

December 11, 2011
by jeffspc88mx
jeffspc88mx's Avatar

Oh, and I just re-installed the USD-serial driver package. Still no luck.

December 11, 2011
by jeffspc88mx
jeffspc88mx's Avatar

OK - I went to Prolific's website (http://www.prolific.com.tw/eng/downloads.asp?ID=31) and downloaded/installed the latest driver (about 2 years younger than the NerdKits one) and I now have a cu.usbserial and a tty.usbserial file in my /dev folder (NOTE: These files only show up when the cable is connected - not sure why that is, but moving on....)

I can't test it with the temp sensor kit until tomorrow. Update to follow.

BTW, OS X Lion wanted to configure this cable as a new modem. I just told it to ignore it as a network device. I'm not sure I want it to try to handshake to my MCU or not. We'll see.

December 12, 2011
by jeffspc88mx
jeffspc88mx's Avatar

Success. The new driver from Prolific loaded a "tty.usbserial" file in my /dev folder, and that's what I pointed the makefile to and everything works.

I should point out that the Mac sees the serial cable as a modem and will ask you to configure it as such. I just left mine as "Not configured" and it's apparently not a problem.

December 25, 2011
by abulva2
abulva2's Avatar

Thanks. I had the same problem, it did not even appear when plugged in, except I did have a COM 7 port already there. I have the most recent macbook air for reference. The chip displayed the initialload script after programming so it was successful. The new driver was necessary from prolific.

May 24, 2014
by M_Fly
M_Fly's Avatar

This approach worked perfectly. Was able to download and install the appropriate USB drivers, also had to download a developer program for the Mac, modified the initialload.c file to experiment a bit, and voila! Everything worked and the LCD screen was modified as I had programmed. Thanks for the link to Prolific. Now onto the temp sensor, bought a servo motor yesterday, and eventually, to thrust vector control!

August 29, 2017
by bhh1988
bhh1988's Avatar

I'm on Mac 10.11.6 and these instructions still work (original manual's instructions did not).

Post a Reply

Please log in to post a reply.

Did you know that 20 LEDs can be controlled from 11 microcontroller pins, to make a twinkling heart outline? Learn more...