NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » can't read or write to mcu

March 19, 2011
by Ace
Ace's Avatar

I was using my nerdkit today and everything was working fine, then I tried to write to the mcu again and got this: stopped I wrote to the mcu once or twice before I got this error message and it worked fine. Now not only can't I write to the mcu, but when I move the switch to read mode, nothing happens. It's dead.

I have checked all connections, tried different batteries, tried to upload different programs, and nothing. Any suggestions?

March 19, 2011
by hevans
(NerdKits Staff)

hevans's Avatar

Hi Ace,

The most likely culprit here is a dead battery. Are you sure the new batteries you tried were fresh? Perhaps you can try connecting USB power to rule out a battery issue. The problem could also be a loose crystal, or maybe a loose reset line. If none of these things are the issue then it is possible your chip is just dead. Do you remember anything happening that might have caused your chip to fry? Perhaps a crossed wire or a spark?

Humberto

March 19, 2011
by Ace
Ace's Avatar

Hi Humberto,

I've tried different batteries and no change. Didn't see any spark or crossed wire, everything seemed normal. Haven't even had this for 30 days, I thought the chip would last longer than that. It was working fine, then nothing.

March 20, 2011
by Ralphxyz
Ralphxyz's Avatar

The chip will last a lot longer than 30 days, however I have a collection of them and LCD's at $15.00 a pop that "SOMEONE" did something to and now they no longer work.

Ralph

Post a Reply

Please log in to post a reply.

Did you know that multiple microcontrollers can communicate with each other? Learn more...