NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » USB Serial Converter not working in Windows 7 64bit

December 29, 2010
by TheCajun
TheCajun's Avatar

I found a thread which posted another driver to use. I've tried both that one and the one downloaded from download page. All I get is a splat in device manager.

December 29, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi TheCajun,

Can you be more specific as to what you mean by splat in the device manager. Does it show up at all? Is it possible the black and red wires on your cable are shorting out and causing a short that causes your USB Port to shut down immediately?

It is possible your cable was just damaged during shipping. Does windows make any indication that something was plugged into the USB Port? Most of the time there is at least a beep and a little indicator bubble when something is plugged in that it does not recognise.

Humberto

December 29, 2010
by TheCajun
TheCajun's Avatar

I have this working on a Windows XP. However, I need it to work on a laptop running Windows 7 64bit. So the USB-Serial convert and cable is fine. When the drivers are installed it shows up in device manager under Ports as Prolific USB to Serial Converter with a yellow triangle and an exclamation point (with the driver posted in forum). With driver downloaded from download page it shows as 'Other' and only USB Serial Converter. When I plug in the device, Windows does make the USB device found sound.

December 29, 2010
by mongo
mongo's Avatar

Are you installing the W7 driver? It is a little different from the XP driver. If you have it installed, and the computer recognizes the module, it should also display a little dialog box saying that it is ready to be used.

December 29, 2010
by TheCajun
TheCajun's Avatar

I tried the driver supplied in a link on the forum about Windows 7 drivers. I also tried the only drivers available on the download site. None were labeled W7.

December 29, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi TheCajun,

That is quite strange. Could it be a permissions issue when installing the driver? I'm not too familiar with with Windows 7, but is it possible you need to run the installer as administrator. There is also a driver on the Prolific website that appears to be a little newer than the one we currently link to, it claims it has support for Windows 7 64 bit, perhaps you can try that one. Let us know if you have any luck.

Humberto

December 30, 2010
by TheCajun
TheCajun's Avatar

On every attempt I did right click, run as administrator.

I also tried the new driver in the link provided to Prolific. Still now luck. Here is what is in the event log when device is plugged in.

I don't know how to post this as it has removed the HTML code. I hope you can still read it.

Log Name:      System
Source:        Microsoft-Windows-Kernel-PnP
Date:          12/30/2010 12:37:18 PM
Event ID:      219
Task Category: (212)
Level:         Warning
Keywords:      
User:          SYSTEM
Computer:      RubinD
Description:
The driver \Driver\Ser2pl failed to load for the device USB\VID_067B&PID_2303    \6&2d7e1374&0&2.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
<Provider Name="Microsoft-Windows-Kernel-PnP" Guid="{9C205A39-1250-487D-ABD7-E831C6290539}" />
<EventID>219</EventID>
<Version>0</Version>
<Level>3</Level>
<Task>212</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2010-12-30T19:37:18.863615400Z" />
<EventRecordID>27438</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="52" />
<Channel>System</Channel>
<Computer>RubinD</Computer>
<Security UserID="S-1-5-18" />
  </System>
  <EventData>
<Data Name="DriverNameLength">36</Data>
<Data Name="DriverName">USB\VID_067B&amp;PID_2303\6&amp;2d7e1374&amp;0&amp;2</Data>
<Data Name="Status">3221226536</Data>
<Data Name="FailureNameLength">14</Data>
<Data Name="FailureName">\Driver\Ser2pl</Data>
<Data Name="Version">0</Data>
  </EventData>
</Event>
December 30, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi TheCajun,

If you indent the bock as code the forum software won't interpret it as HTML.

Still this error definitely has me stumped. I know we have had customers who got the cable to work fine on 64 bit Windows 7. I don't have a 64-bit Windows 7 computer here to try and recreate the issue. I'll keep thinking and digging around, perhaps I can find something. In the meantime keep us posted if you find any solution. If there is anybody here who knows something to try please let us know!

Humberto

January 01, 2011
by TheCajun
TheCajun's Avatar

I can now flash the device from the laptop. However the workaround is unconventional. I installed Virtualbox and created a Windows 2K virtual machine. This VM has no problems with the USB to Serial driver and I have successfully flashed this way.

This is all so my son can do his science fair project.

Thank you all for your time and efforts.

Durwin

January 07, 2011
by Steven
Steven's Avatar

Which installer are you running? In the main directory of the ZIP archive is two executables. One is "PL-2303 Driver Installer" and the other is "PL-2303 Vista Driver Installer." You need to run the Vista installer (try running it as Administrator as well). This works fine for me.

March 20, 2011
by fhmartinez
fhmartinez's Avatar

I had the same problem, but it was solved using this http://www.prolific.com.tw/support/files/%5CIO%20Cable%5CPL-2303%5CDrivers%20-%20Generic%5CWindows%5Callinone%5CPL2303_Prolific_DriverInstaller_v130.zip

and running it as Administrator, with the cable unplugged.

Hope it works.

April 12, 2011
by oldphart
oldphart's Avatar

I had a similar problem with Win7/64 bit install -- the initial install failed with a message "Can't copy Inf file...". This was running the PL2303_Prolific_DriverInstaller_v1210.exe, not in Administrator mode. Downloaded a newer v130 driver from Prolific and ran as Administrator. Still failed. Ran the old v1210.exe again and chose "Remove" as the install option. Then unplugged the serial cable and re-ran the v130 install program as Administrator. This time, the install claimed success. Plugged in the USB and it showed up as COM4. I imagine that the first, failed install left some half-eaten detritus on the system that interfered with subsequent Administrator install attempts. Perhaps if I had originally run the install exe as Administrator I would not have seen any problem. (this since there does not seem to be any substantive difference between v1210 and v130 from the readme files.)

Post a Reply

Please log in to post a reply.

Did you know that you can control multiple LEDs from one microcontroller output? Learn more...