NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Ledarray_test Error

August 31, 2010
by DrPancake
DrPancake's Avatar

Hello,

I usually do not have to post on the forums because I can usually find the answers by searching. Although I have been looking for a while and cannot find a solution to my problem.

Just set up my LED array. Double checked my connections (although I;m sure it is very likely i connected something wrong still knowing me D:) but am still having the same problem when doing the first Led_array test when trying to upload it.

the cmd reads it and i get the Reading | ####### |100%

then this

avrdude: Device signature = 0x1e950f avrdude: Expected signature for ATMEGA168 is 1E 94 06 Double check chip, or use -F to override this check

avrdude done. Thank you.

make: *** [ledarray-upload] Error 1

Thanks, Brett

August 31, 2010
by Ralphxyz
Ralphxyz's Avatar

Search the Nerdkit forum for "Double check chip".

I had a similar question and my answer was to use 168p not 168.

The -F sytax is like this "AVRDUDEFLAGS=-c dapa -p m168p -F" (no quotes) if you need to override the signature check.

Ralph

August 31, 2010
by DrPancake
DrPancake's Avatar

Worked like a charm, appreciate it!!!

Thanks again, Brett

August 31, 2010
by DrPancake
DrPancake's Avatar

actually just for anyone else that has had this problem, changing it to 168p did not work but adding the -F function worked fine. So you can try that also.

Post a Reply

Please log in to post a reply.

Did you know that you can build an analog amplifier with one transistor and a few resistors? Learn more...