NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Project Help and Ideas » USB to Serial Virtual Box

June 10, 2010
by Delrin5
Delrin5's Avatar

I am having trouble getting the "Prolific USB to Serial" component to show up in the Device Manager on WindowsXP running in a virtual session on Sun VirtualBox. The primary operation system is Ubuntu.

I know very little about Linux, but I can follow direction pretty well. I have installed the RS232 driver on the windows side, but when I plug my Nerd Kit into the USB I am not seeing anything on the windows side.

I am thinking I need to SET something in Linux to recognize the USB before VirtualBox can pass it to XP, but I have no idea what I need to do to make this happen. I also might be completely off track with this line of thinking...

Anyone have any ideas?

Thanks,

Delrin

June 11, 2010
by treymd
treymd's Avatar

You need to add your username to the unix group vboxusers I believe it is in order to have access to usb devices.

June 11, 2010
by banerjen
banerjen's Avatar

Why don't you use the Prolific USB to Serial driver for Linux instead!? I don't know why but I too could not get any USB devices to work with SUN Virtual Box. I tried tweaking the Virtual Box settings but to no avail. Try a thumb drive and see whether it's working or not. If not, then you could get some information on the forums dedicated to Virtual Box.

June 11, 2010
by mcai8sh4
mcai8sh4's Avatar

Hi folkes! I've never tried using the NerdKit on a virtual machine, but to get USB devices working I think you have to 'turn them on' ie. in the devices menu, goto USB devices and mount them. Thats what I have to do to get any USB things recognised (thumb drives etc).

Keep us posted if you get it working, it would be handy to know about so I don't have to boot to windows if I want to test something for someone elses machine.

Good luck,

Steve

June 11, 2010
by Delrin5
Delrin5's Avatar

@treymd: Do I have to create this group? I did not see it in the User Management - Groups tab (With "Show System groups" checked)

@mcai8sh4: I checked the box to automount removable devices in the Removable Devices area of the system settings

But no luck yet.

June 11, 2010
by Delrin5
Delrin5's Avatar

It just dawned on me... if I am not seeing this in Linux how can I see anything in a guest Operating system.

Post a Reply

Please log in to post a reply.

Did you know that our USB NerdKit works on Windows, Linux, and Mac OS X? Learn more...