NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Project Help and Ideas » laptop (XP) ledarray-upload error 1

May 12, 2010
by azantel
azantel's Avatar

Hi, I'm using an older laptop (xp) has 1 usb port, ps/2 port ect.. when i plug in my nerdkit in shows as other devices -> ?!usb-serial controller. Nothing under Ports (com and LPT) also i need to install a driver..

when i run cmd and run the make file it says ledarray-upload error 1 I'm assuming that means its the wrong port. I change the make file to com1(as mentioned in the guide) and seems to get a better result connecting to programmer.. after 5-10min it goes

avrdude:error:buffered memory access not supported. maybe it isnt a butterfly/avr109 but a avr910 device?

Do i need to make another makefile i've tried going to the www.eng.hawaii.edu/tutor/make/ site, but doesn't seem to exist anymore i've tried google.. i've tried programmers notepad2 --> make all (same code) but also same result.. any help would be great. thanks

May 12, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi azantel,

The stuff you are getting on the device manager suggests to me that the driver for the programming cable did not install correctly. Did you get any errors while you were installing the driver? Try reinstalling the cable driver and make sure you try installing it as a user that has administrator privileges. Let us know if that fixes it.

Humberto

Post a Reply

Please log in to post a reply.

Did you know that two resistors can be used to make a voltage divider? Learn more...