NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » First Time HELP!!!!!!!!

April 20, 2009
by tommy
tommy's Avatar

Hey! I just got my nerdkit in the mail 2 days ago and its soooo much fun but I cant seem to be able to load a program onto the chip. I followed all of the directions in the guid but it wont work! I plug it in and find out its in COM4 so I go to initialload makefile and I change USB0 to COM4 and run the make command ( after doing cd Desktop/Codo/Code/initialload) and I get avrdude: ser_open(): can't open device "/dev/ttyCOM4": The system cannot find the path specified. I dont understand I have tried different ports and everything and it just wont work. Can you pleeeeas help?

Thank You

April 20, 2009
by DonNYC
DonNYC's Avatar

I think you replace the whole "/dev/ttyUSB0" with "COM4" not just the "USB0" part.

So is should read;

AVRDUDEFLAGS=-c avr109 -p m168 -b 115200 -P COM4

I am using a Mac so I cant say for sure.

Don

April 20, 2009
by hevans
(NerdKits Staff)

hevans's Avatar

Your right DonNYC,

You need to replace the whole "/dev/ttyUSB0". I apologize if the instructions are not very clear. I'll try to make it clearer in a future version of the guide.

Humberto

April 20, 2009
by wayward
wayward's Avatar

Yeah, it's the vestige of early DOS. It tried to emulate special files for accessing the I/O devices as they existed in UNIX (perhaps VMS too?), but without a dedicated directory to keep them in. So today in Linux, *BSD and others, you have /dev directory where those special files reside, and in Windows you still can't create files named LPT, COM1...4, PRN, because those names are reserved for compatibility purposes. (Go ahead, try it! :) )

Cheers, Zoran

April 20, 2009
by tommy
tommy's Avatar

Thank You so much for your quick replys and I will try that out right now! You are truly supportive and will be verry helpful for im 13 and may have a few questions! Thank You so much once again... Have a great Night!

April 21, 2009
by tommy
tommy's Avatar

Hey sorry I have another question :). When I plug it in and run the new make command I get an error avrdude: error: buffered memory acces not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?

What does this mean and how do I make it work? Thanks!

April 21, 2009
by tommy
tommy's Avatar

Sorry for another one but also I cannoth get the normal nerd kits preloaded program to work... I get the first and third line but no charachters just sploches and I have checked everything 4 times and press everything in but it still wont work can you help?

April 21, 2009
by mrobbins
(NerdKits Staff)

mrobbins's Avatar

Hi Tommy,

The best thing to do is for you to take a close-up photo of your breadboard and e-mail it to us at us. If your camera has a "macro" mode for close-up focus, which is sometimes designated by a flower icon, then that may help you take a good picture. We'll see if we can spot anything out of place and will probably be able to help you quickly!

Mike

April 30, 2009
by Pheryllt
Pheryllt's Avatar

I had the same issue.

Running Windows Vista 64 Home Pro.

What fixed the problem for me was

1) Run the installer for AVR as Admin (precautionary measure as Vista has brain farts if you don't do everything as admin)

2) Make sure you open the command window as Admin also (Start/All programs/Accessories/Right click on Command Prompt/Run as Admin)

3) Replace dev/ttyUSB0 with your com port (COM4 on mine) replace that entire portion of the command not just the USB0.

works like a charm now.

May 16, 2009
by mfspunk
mfspunk's Avatar

Hey there, i had the same problem. (WinXP) Make sure your comport is < 4, i set it to 2. make sure you connect pin 14 to - before you connect the battery.

THEN, run the make file /w adjusted com port.

Post a Reply

Please log in to post a reply.

Did you know that NerdKits believes in the importance of a mixture of meaningful topics, clear instruction, and engaging projects? Learn more...