NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Can't get the "Make" Command to run

December 30, 2009
by ffogarty5
ffogarty5's Avatar

Just set up the kit and made it past the LCD and code downloads. I am having a problem with the MAKE command in the DOS Command Box. Says there is no such file or can’t find it. I don’t remember the exact error (on another computer at home) System is MS XP. Also made sure I was on COM port #4. Any Ideas ? n00b Chris

December 30, 2009
by emh593
emh593's Avatar

Are you in the correct directory? You need to be in the same directory as the code. Like if it's in your downloads folder, make sure that the command line looks like this.

C:\Users\Username\Downloads\Code\Code\initialload>

Replacing "username" with your username of course.

February 25, 2010
by ELMo_0007
ELMo_0007's Avatar

The same thing is happening to me, every time I try to run the "make" command I get the error:

'make' is not recognized as an internal or external command, operable program or batch file.

I am running Microsoft Vista Home Premium 64 Bit, and have triple checked my directory, it contains "makefile" and "initialload.c"

February 25, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi ELMo_0007,

That error comes from WinAVR not having been installed correctly for some reason. WinAVR is a suite of different programs that it installs, 'make' is one of them. Are you running on Vista? If so you probably want to run the installer as administrator, that might solve the problem. Perhaps just reinstalling WinAVR might do the trick. Let us know if you still can't figure out the issue. We will do what we can to get to the bottom of it.

Humberto

February 25, 2010
by bretm
bretm's Avatar

The error message means that the folder where make.exe lives isn't listed as one of the folders in the PATH environment variable. Type "set path" to display the list of folders where it's looking for make.exe (and any other command that you type that's not a built-in command).

WinAVR setup automatically adds itself to the PATH variable so you should see one or more folders that start with C:\WinAVR or whatever the installation location was. It may have failed to do this, and running as Administrator may correct it.

February 25, 2010
by Rick_S
Rick_S's Avatar

Also, if you haven't rebooted after the install, the path may not be in effect. As the others have stated, best results in vista is to install as an actual administrator (enable the account), and reboot after the install. Alternatively, I have had success running the install as administrator from my regular login with a subsequent reboot afterwards.

I don't run a 64bit OS so I don't know if that is a factor or not.

Rick

February 26, 2010
by ELMo_0007
ELMo_0007's Avatar

Thank you for all the quick replies, I reinstalled WinAVR, and now it seems to work fine. I am confused as to why it didn't install correctly the first time, however, as I ran the install while logged in as the admin and restarted the computer afterwards. Oh well, as long as it works now.

Post a Reply

Please log in to post a reply.

Did you know that hobby servos are controlled through a particular kind of PWM (Pulse Width Modulation) signal? Learn more...