NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Chip won't erase

December 06, 2009
by rdalton
rdalton's Avatar

I've gotten through the tempsensor and loaded it. It ran fine. Then i edited it and when i try to run the new make, it tells me

"ardude: erasing chip

avrdude: error: programmer did not respond to command: chip erase"

Now I get this error when running the initialload make file also. I'll send a picture as soon as I can but no wires have changed since it did work. I'm worried I flipped a bit that says 'make this permanent' on the chip.

I've tried unplugging everything for about 1/2 hour, no change.

ps. Random Note On page 54 of the documentation where it gives the line:

while(l);

Can you change that so it's not an 'l'? I spent an hour because i thought it was the numeric one. I got more confused because the 'i's below it looked like 'l' after my pdf changed the size a bit.

December 06, 2009
by pbfy0
pbfy0's Avatar

it is a numeric one.

while(1)

for your first problem, try a new battery. That was my problem when I had a similar error

December 06, 2009
by rdalton
rdalton's Avatar

I have tried the 'program mode' switch in both up and down positions. I tried a new battery and no luck.

(sorry, i fought with the 'l' and '1' so long, i forgot which one it was supposed to be. thanks)

December 06, 2009
by mcai8sh4
mcai8sh4's Avatar

I know this sounds obvious, but I'll throw it in - have you checked every wire, in detail. On a few occasions I've had wires become dislodged, and even after checking not noticed.

I don't think it's possible to alter the fuses so you can't program it using the Nerdkits header - so that should be some relief.

If all else fails - unplug everything, and start from scratch - it's annoying but at least you know it's then not something stupid - maybe upload a picture of your board, and the error. The more info you give, the better the chance someone will spot something.

If all else fails, try emailing support at nerdkits dot com - if it's fixable, it will be fixed.

Best of luck

-Steve

December 07, 2009
by rdalton
rdalton's Avatar

I think I solved it.

If i connect the black wire from the battery to pin 29, it works. If i just connect it to the blue rail, it doesn't.

on page 24 of the manual it says to connect to the blue rail but all the pictures show it connected to pin 29.

I understand pin 29 should be the same as ground but somehow, it isn't exactly the same. Maybe the black battery wire needs to be closer to the voltage regulator?

Thanks for the help.

December 07, 2009
by Rick_S
Rick_S's Avatar

Do you have the wire from the blue rail to row 29? If so, it shouldn't matter if the wire is in the blue rail or row 29. Both should work. Maybe your battery wire just wasn't making a good connection in the blue rail?

Glad to hear you got it going though.

Rick

Post a Reply

Please log in to post a reply.

Did you know that one NerdKits customer controlled a laser pointer with his computer using a microcontroller? Learn more...