NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » mac osx 10.8.2 no longer supports gcc 4

March 18, 2013
by keith712
keith712's Avatar

a couple weeks ago i had an accident with my macBook air... fortunately i had backed up less than five minutes before the accident... hardware is ok now, my repair people also installed the latest version of osx and i sucessfully reloaded my backup...

when i tried to compile my latest avr project i got the following:

k712:rtACS1.x k712$ make
-bash: make: command not found

when i tried to tell the system which compiler to use i got the following:

k712:~ k712$ avr-gcc-select 4
avr-gcc-select is not supported any more.
This version of CrossPack for AVR Development comes with gcc 4 only.

i'm stuck... does anyone have a suggestion for what i should do next?

March 19, 2013
by Rick_S
Rick_S's Avatar

Buy a PC -- LOL Wink

Seriously, I'm primarily a PC guy, though I do own an old mac mini that hasn't been turned on in months. Hopefully one of the other mac members can get on board and help.

Rick

March 19, 2013
by Noter
Noter's Avatar

I think you need to reinstall crosspack from the download. Most applications have to be reinstalled after the OS is replaced.

March 19, 2013
by keith712
keith712's Avatar

Rick... very funny!!!! please lets not ignite the pc vs mac thing in this forum... besides i think these microcontrollers are way-cooler then all the magic you can buy from microsoft or apple...

Noter... before i started working on my project yesterday i downloaded and installed both the latest prolific usd-serial driver and crossPack 20130212... then i got the fustrating messages... after reading your suggestion this morning i reinstalled crossPack again from the dmg file that i hadn't trashed yet and... voila... the make command works!!! now i just have to correct the usual incredibly long list of errors the compiler found in my source code...

thanks as always!!!

Post a Reply

Please log in to post a reply.

Did you know that the Timer/Counter modules on the microcontroller can be configured to output a PWM (Pulse Width Modulation) signal? Learn more...