NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Everything Else » Linux: /dev/ttyUSB0 permission denied

May 28, 2012
by missle3944
missle3944's Avatar

Hi guys,

I recently updated and rebuilt my computer and its running ubuntu 12.04 lts. I loaded all the programs for the serial to USB,nerdkit,avr files. But when I type "make" it says /dev/ttyUSB0: permission denied. It worked fine on my old machine: Pentium 3 xubuntu 11.04.

I see the prolific to usb driver when I type lsusb in terminal. Any Recomendatoins?

Thanks, Dan

May 29, 2012
by hevans
(NerdKits Staff)

hevans's Avatar

Hi Dan,

That's quite odd. I am having no problems with the device on 12.04. Have you tried doing a "sudo make". Its a bit weird to give make sudo privilages, but I'm curious if it will work.

Humberto

May 30, 2012
by missle3944
missle3944's Avatar

Humberto,

I was able to get it to work yesterday! Thankfully. I have no idea why 12.04 is like that. 11.04 seemed to work fine.

-Dan

Post a Reply

Please log in to post a reply.

Did you know that an electroluminescent backlight for an LCD panel requires hundreds of volts AC to run? Learn more...