NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Strange Power Issue

March 10, 2012
by tommytwoeyes
tommytwoeyes's Avatar

After I completed the temperature monitor project, I had everything working great - worked fine powered by the 9V battery or by the USB-serial cable.

I set the project aside to do other stuff for a few days. Now, if I power the circuit with more than 5V, the screen displays the black rectangles on all four rows. If I view the screen from just the right angle, however, I can see the temperature reading and all the other text the program is supposed to display, so I know it's working.

But, if I supply the circuit with 5V or less, it works perfectly.

Initially I assumed that something must be wrong with the voltage regulator, so I replaced it with a new L7805. The problem persists, though.

I've tried re-wiring everything also, but no joy.

Does anyone know what's going on here? Thanks in advance!

Tom

March 10, 2012
by tommytwoeyes
tommytwoeyes's Avatar

Nevermind. I figured out what I'd done wrong. Since it had been a few days since I worked on the circuit, I forgot that the positive voltage from the power source went to the input pin of the 7805, and I plugged it into the positive power rail.

A bit embarrassing for me, but hopefully this will help anyone else who has a similar problem.

What is the potential extent of any damage I might have caused with this mistake?

March 10, 2012
by Rick_S
Rick_S's Avatar

When you say "if I power the circuit with more than 5V" do you mean when you use a battery? If so, have you tried a fresh battery? Batteries that may measure close to 9V will drop low under a load and your regulator won't do it's thing. It needs about 7 volts to work properly.

If you are using some other source of higher voltage such as an AC adaptor, what are the specifications on it.

Posting good overhead photo's of your setup often helps as well. Sometimes we can see something you may be overlooking.

Rick

March 10, 2012
by tommytwoeyes
tommytwoeyes's Avatar

Thanks, Rick. It was my mistake - I'd forgotten to connect the positive battery terminal to the input of the 7805 when I rebuilt the circuit. I connected it to the positive rail of the breadboard, which is why it didn't work. D'oh!

Post a Reply

Please log in to post a reply.

Did you know that you can build a circuit to convert the "dit" and "dah" of Morse code back into letters automatically? Learn more...