NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Trouble getting USB to program MCU

December 29, 2011
by nkrueger
nkrueger's Avatar

So I am trying to get the initalload.c program to work with my nerdkit. Everything up until the final step where 'AVRDUDE' attempts to communicate with the MCU is working. I have changed the port to COM4 and done so in the makefile. The error I am getting is that AVRDUDE doesn't recognize the connected device. It says:

Connecting to programmer: . Found programmer: Id = "Huh? Go"; type = ' Software Version = t. ; Hardware Version = '.S avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device? make: *** [initialload-upload] Error 1

Not sure what to make of this. I am confident I wired everything correctly and have tried cycling power to the chip and disconnecting and reconnecting the USB cable to no avail. Also just to be sure I have tried the programming switch in both positions. I have tried changing the baud rate to something lower in the device manager and made the corresponding change in the makefile, this resulted in a different gibberish for the Id = "Huh?" and other feilds from the AVRDUDE output.

One other question, what does 'UP' and 'DOWN' mean with respect to the programming switch, this jargon is very ambiguous to me.

December 29, 2011
by hevans
(NerdKits Staff)

hevans's Avatar

Hi nkrueger,

The "Huh? Go" in your error message tells me your chip is not in programming mode. "Up" and "Down" is admittedly ambiguous. By "up" we mean towards the chip, such that pin 14 of the MCU is tied to GND by the switch. When the chip boots the bootloader checks this pin to see if it is low, if it is it remains in the bootloader and awaits a new program, if it is high (pulled up by an internal pull up resistor) it jumps to the program code and runs the last loaded program.

My guess is your programming switch is not installed correctly, if you include a good close up picture of your setup we would be glad to take a look and see what we can find.

When you are successfully in programming mode you should see two black lines on the LCD, and not the original congratulations message.

Humberto

Post a Reply

Please log in to post a reply.

Did you know that spinning a permanent magnet motor makes a voltage? Learn more...