NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Trouble uploading program

September 03, 2011
by plehrer
plehrer's Avatar

Hi, I keep having trouble uploading program to the LED Array kit on VMware Ubuntu Linux. This is the message I get after running make:

avrdude -c avr109 -p m328p -b 115200 -P /dev/ttyUSB0 -U flash:w:ledarray.hex:a

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
make: *** [ledarray-upload] Error 1

I checked to make sure there is a device ttyUSB0 in the dev folder and I ran dmesg a couple of times.

I think the trouble must have something to do with the VMware linux because I have no problems up loading programs in Windows 7. Can anyone help me out?

September 10, 2011
by Ralphxyz
Ralphxyz's Avatar

plehrer , I hope you found your answer.

What is your base Operating System that you are running VMware on?

Are you running the free VMware server or on a payed for client?

Ralph

September 13, 2011
by plehrer
plehrer's Avatar

Hi Ralph,

I am using the free version of the VMware server running on Windows 7.

I discovered that I am able to upload a program when only the LED array kit's USB-to-serial cable is connected to my computer, and I am running Linux on top of VMware.

If I have another USB-to-serial cable connected to my computer to another Nerdkit, I can't upload a program at all when running Linux on top of VMware.

I have the suspicion that if I had a dual boot machine instead of running Linux on top of VMware, I probably wouldn't be having these upload problems.

The reason I am running Ubuntu Linux on top of VMware to interact with the LED array kit is because I can't get the feed-reader.py program to work on my Windows 7 OS. I tried turning off the fire wall when running Windows, but I still can't get feed-reader.py to run successfully on Windows.

Peter

Post a Reply

Please log in to post a reply.

Did you know that you can make a spooky Halloween Jack-O-Lantern with a microcontroller? Learn more...