NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » PL2303

NerdKits » Forums » Support Forum » PL2303 (6 posts)
July 05, 2009
by Photon0gen
Photon0gen's Avatar

I'm on a mac and trying to program my nerdkit. It was working for a while, did the tempsensor project. But now I cant find the cu.PL2303-0000201A driver thing in the /dev directory. It used to be there. The tty.PL2303-0000201A is gone as well. Is there something I'm supposed to do to load the driver? I have tried uninstalling and reinstalling it.

July 06, 2009
by mrobbins
(NerdKits Staff)

mrobbins's Avatar

Hi there,

A few things I can recommend trying:

  1. Does the device come back when you disconnect and reconnect it?
  2. Are you sure that no programs are still running trying to access that port (whether an avrdude, or screen session, or any code you wrote)? If so, it may prevent the device from coming back.
  3. Can you try without the black extension cable?

We'll get to the bottom of this!

Mike

July 06, 2009
by Photon0gen
Photon0gen's Avatar

Thanks for the help Mike. For anybody who has this problem, it is neccessary to have the kit plugged into to the computer for the driver to be loaded. It was a quick fix.

July 09, 2010
by lsoltmann
lsoltmann's Avatar

I'm having a similar problem. The USB cable was working fine and then all of a sudden it stopped working. I checked the dev folder and there is no more cu.PL2303-..... Doesn't matter if I unplug it and replug it, nothing changes. I tried the fix that was suggest by Photon0gen about having the cable plugged in while the driver was being installed. Didn't change anything. Also tried resetting the PRAM with no success. Any suggesting on how to solve this?

July 10, 2010
by Ralphxyz
Ralphxyz's Avatar

Isoltmann, of course you can always treat it as a "windows" problem and reboot :-)

Try rebooting with and without the cable plugged in.

You can tty ps and kill in the terminal to see and kill any related processes.

Ralph

July 10, 2010
by lsoltmann
lsoltmann's Avatar

I tried the reboot and still nothing. I also looked for any any other processes that might cause the cable to not function and no luck there either. I tried the cable on a different computer and it did not work there either. So I tried a different USB-serial cable that I have and it immediately shows up in the /dev directory. I switched it out for the nerdkit cable and nothing. So based on this I think the cable provided with the nerdkit stopped working. Not sure why this would happen, but everything is better now.

Post a Reply

Please log in to post a reply.

Did you know that NerdKits believes in the importance of a mixture of meaningful topics, clear instruction, and engaging projects? Learn more...