NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » font.h update2

June 13, 2009
by Farmerjoecoledge
Farmerjoecoledge's Avatar

Just sittin here feeling like a dam fool.Guess what it's included. My excuse i read this first: You should not need to modify the Makefile, however you will need to run 'make font.h' first if you modify the font.txt file. The font.h target uses python to build the font.h file from font.txt. After that, running 'make' should compile and upload the code. It just dawned on me when nobody answered to look in the code. So now because the marquee wasn't working properly thinking that it might be the chip i reinstalled tempsensor. It worked exactly as it should. Now the ledarray2 won't install again. Does anybody know what: no rule to make target means? ledarray2.c needed by ledarry2.hex This worked yesterday but not today and i didn't change a thing.

March 11, 2010
by norby31
norby31's Avatar

I'd like to know what "no rule to make target" means also.

March 13, 2010
by hevans
(NerdKits Staff)

hevans's Avatar

Hi norby31,

"No rule to make target" means that make was not able to find a target to make the particular dependency it was asked to create. The Make program is a series of chained "targets" each of which have a set of dependencies (other targets) it must create or find before it can execute each target. The error itself means that Make was asked for a target it doesn't have a definition for. This could mean that you misspelled one of the targets and make can't find it (happens a lot to me), but more often it means that something is in the wrong folder. For example in all our our projects the .c file is a dependency in the .hex and .o targets. If the .c file was not found in the folder it will throw that error, as Make cannot find the .c file and there is no rule to make that target.

Let me know if any part of that doesn't make sense. I'll try to explain it better.

Humberto

March 15, 2010
by Farmerjoecoledge
Farmerjoecoledge's Avatar

Well Humberto...finally.

and...usually a reboot will fix that. The gcc goes blind after awhile or because it's lazy, if you use it at all for anything it needs to be reset just like the reset on the board. The .c file it can't find didn't move.

fjc

Post a Reply

Please log in to post a reply.

Did you know that a square wave sounds different than a sine wave? Learn more...