NerdKits - electronics education for a digital generation

You are not logged in. [log in]

NEW: Learning electronics? Ask your questions on the new Electronics Questions & Answers site hosted by CircuitLab.

Support Forum » Can't Access Serial Port or Send New Program Chip

December 24, 2010
by rpeiffer
rpeiffer's Avatar

Just re-dug my nerdkit out that I put together last year (love it!). I had completed the "temp sensor" project successfully. Moved my project to a new breadboard. Fired it up and it the program ran as before (successfully). Wanted to see if I could view the output being sent to the serial port (in addition to the LCD output). (Linux) Minicom would connect, but no output. I could see the LED flashing on the Serial to USB converter. From there went to see if I could just recompile and send the program back up to the chip. Unplugged battery, flipped switch grounding pin 14, re-plugged the battery in and ran make. Got the following output:

avrdude -c avr109 -p m168 -b 115200 -P /dev/ttyUSB0 -U flash:w:tempsensor.hex:a

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding make: *** [tempsensor-upload] Error 1

Re-checked the header wiring: Black to ground, red to +5v, yellow to pin 2, green to pin 3. Brand new 9v battery. Tried moving to a different USB port (same computer I did the original programming on), no go, same error. I did notice, with pin 14 grounded (switch on), LCD screen has top row of solid "black" blocks. Can't recall if it was this way the last time I had the kit together and the programmer was working.

Did some digging on this forum. This error message is pretty generic, and have found a couple of occurrences that turned out to be wiring on the header (thus the recheck of wiring). Pretty convinced I've at least got the header wiring correct.

Any help would be appreciated! I am a software engineer by trade (developing in a Linux environment), but a newbie on the hardware side.

Thanks!

December 24, 2010
by rpeiffer
rpeiffer's Avatar

Just a follow up to my own post. Disconnected battery, did a continuity check between connector for adapter and breadboard (pins 2 and 3). Good continuity. Plugged connector back into serial to USB converter. Everything come up (programs load, I can read the serial port), however..... Periodically when sending a program up, avrdude will complete the write, but then hang when doing the verify (reading it back). It will eventually error out as described in the original post. Strange. Something must be flaky in one of the connections somewhere. Happens about 1 in 15 to 20 uploads. When it happens, I can immediately run it again, and it will function fine.

Post a Reply

Please log in to post a reply.

Did you know that NerdKits believes in the importance of a mixture of meaningful topics, clear instruction, and engaging projects? Learn more...